HSMM-MESH™ Forum :: General
Welcome Guest   [Register]  [Login]
 Subject :Node Internet Sharing.. 2012-06-10- 22:29:03 
W5RCH
Member
Joined: 2012-05-29- 14:15:07
Posts: 4
Location

Playing around with one of my nodes I decided to set it up as a Gateway. I enabled the Gateway box, save & reboot, and nothing happened. NT5LA let me know about putty, and how I needed to edit the config file for it to work (because I tinker before I read lol). So we did, and still no internet.

After messing with it a couple days I got it to work! The main problem was I enabled the Gateway box before editing the config file.

I had to un-check the Gateway box, save & reboot, re-check the Gateway box, save & reboot. After this it started working fine. I did change the Wan DNS servers to 4.2.2.2 & 4.2.2.3 just because I always use them.

For my configuration I used a static ip on the wan side. I use an Untangle sever for my firewall with 6 nics. I configured one of the nics on Untangle to 192.168.0.1, and gave the Wan ip of the node 192.168.0.2 with 192.168.0.1 as the gateway. Then I bound one of my external static ip's to the Mesh nic in Untangle. Works pretty good!

Hope that helps someone that enabled the box first lol,
Rich ~ W5RCH

IP Logged
 Subject :Re:Node Internet Sharing.. 2012-08-07- 05:42:29 
N7RXE
Member
Joined: 2012-07-25- 18:56:05
Posts: 6
Location
I am curious if editing the config file is still necessary? Hardware = WRT54G version 3 Firmware uploaded was 0.4.3 of the WRT54g version Wan address shows that it is getting a valid IP address from my network via DHCP, and the default gateway address returned is correct, but I can not connect to the internet. Mesh Gateway box is checked. kevin
IP Logged
 Subject :Re:Node Internet Sharing.. 2012-08-07- 07:38:46 
W5RCH
Member
Joined: 2012-05-29- 14:15:07
Posts: 4
Location
Hi Kevin, I just posted a reply, and it didn't show up, weird. I've been knee deep in server installs, so I haven't had time to try 0.4.3. I'm still running 0.4.2 here. A local HAM brought me his wrt54g because it wouldn't flash to 0.4.3, I ended up putting 0.4.2 on it. I hear 0.4.3 fixes this issue so you don't have to edit the config. I would try rebooting your internet modem, normal router, and then the Mesh node. If that doesn't clear it up, you might want to login with putty, (or what ever you prefer) and try pinging each of the IP's. If you don't get a reply then you'll have to update them with valid IP's. Unless it's been fixed, it seems when you check the gateway box it only checks the IP's that first time. Which is why I mentioned unchecking the box, reboot, recheck, reboot. This way you force it to check the IP's again. Let me know how it goes, Rich ~ W5RCH
IP Logged
 Subject :Re:Node Internet Sharing.. 2012-08-07- 15:27:09 
K5KTF
Admin
Joined: 2010-01-18- 23:04:04
Posts: 213
Location: 30° 31' 7'' N 97° 52'
  

For an internet gateway to work after power-cycles/reboots, you need to have 0.4.3 installed.
0.4.3 installs new IP's (of this web server) to ping against to verify there IS a connection, before actually turning on the gateway function at each boot.

Or you can manually install them, if you SSH in and edit the config file, the info is posted elsewhere on the site.

Also check to make sure you are plugging your internet connection to the WAN port.

With 0.4.3/IP's fixed and a connection to WAN, reboot the node and it should make it happen.

KTF


IP Logged
B-) Jim K5KTF EM10bm Cedar Park, TX :star:
 Subject :Re:Node Internet Sharing.. 2012-08-08- 09:29:59 
N7RXE
Member
Joined: 2012-07-25- 18:56:05
Posts: 6
Location
Thanks for the tips guys, I am up and running just fine now. In a nutshell, While trying to figure out why it did not work, I had changed the DNS enteries to my local corp network ones. So changing them back to the Google Public DNS did the trick. The 0.4.3 works really slick as a gateway.
IP Logged
 Subject :Re:Node Internet Sharing.. 2012-08-08- 12:14:18 
w5jmw
Member
Joined: 2012-07-30- 12:39:27
Posts: 2
Location
so jim you are saying the internet conn does not go to the internet recep? but to one of the wan receps...Just got my second node up and going,trying to get the basic internet route..nothing yet,jmw
IP Logged
 Subject :Re:Node Internet Sharing.. 2012-08-10- 13:56:38 
K5KTF
Admin
Joined: 2010-01-18- 23:04:04
Posts: 213
Location: 30° 31' 7'' N 97° 52'
  

Right, you would need a cable from your internet connection (router/cablemodem/etc) to the WAN port on the node, then check the GATEWAY box in the node setup.


KTF


IP Logged
B-) Jim K5KTF EM10bm Cedar Park, TX :star:
 Subject :Re:Node Internet Sharing.. 2012-08-10- 16:33:14 
K5KTF
Admin
Joined: 2010-01-18- 23:04:04
Posts: 213
Location: 30° 31' 7'' N 97° 52'
  

For the benefit of anyone else finding this in the future, here is what is needed to make this work (Rich and I just discussed it over the phone):

You MUST be on 0.4.3 firmware for the internet gateway to work now, due to recent changes beyond our (the HSMM-Mesh project) control.

You have your modem to the internet, be it cable modem, DSL, even wifi internet. That connects to your regular house router's WAN/Internet port.

On the house router, connect a cable from one of the house router LAN ports to the HSMM-Mesh node's WAN port. Then go into setup and check the Internet Gateway box under the WAN settings, click SAVE CHANGES, and reboot.

You only need to connect ONE mesh node to the internet to give your entire mesh network internet access. Other nodes do NOT need to have a connection to the house router OR does not need to have the Internet Gateway box checked. Just the one is all that needs setup.

These simple steps will give your mesh nertwork internet access.

And remember Part 97 rules.... Its your license !

Jim
K5KTF

IP Logged
B-) Jim K5KTF EM10bm Cedar Park, TX :star:
 Subject :Re:Node Internet Sharing.. 2013-04-03- 10:31:57 
WA2RJP
Member
Joined: 2013-03-17- 09:07:03
Posts: 2
Location

Jim,

That was a simple explanation and worked perfectly. I am a mesh noobie but was able to hook my laptop to one router, the internet to a second and remotely connect to the second and make the changes to the WAN port. After the reboot I had internet!

Now I just need to figure out how to access the serial port on my router. I have a few more people interested in the mesh and grand plans on how to implement it locally.

 

tnx agn,

Jim

WA2RJP

IP Logged
 Subject :Re:Node Internet Sharing.. 2013-04-03- 12:59:52 
K5KTF
Admin
Joined: 2010-01-18- 23:04:04
Posts: 213
Location: 30° 31' 7'' N 97° 52'
  

The serial port(s) pinout is posted online, and a google search should find it easily (google "WRT54G Srial pinout"). Its a standard .10 pitch 2x5 IDC header layout. Just need to plug the 2x5 IDC black header onto it, OR, like I do, and solder directly. The header makes it convenient if you have to take the covers off/board out.

BUT...

To hook to a standard PC serial port, you will need whats called a Level Shifter.

PC serial works at about 12VDC, whereas the WRT's serials are 3.3/3.5, so you need to have a level shifter in between

Also, COM1 is, by default, the console output, so if you only need 1 port, connect to COM2's pins and make things a bit easier.

KTF


IP Logged
B-) Jim K5KTF EM10bm Cedar Park, TX :star:
Page # 


Powered by ccBoard


SPONSORED AD: